summaryrefslogtreecommitdiff
path: root/ospfd/Makefile.am
diff options
context:
space:
mode:
authorgdt <gdt>2004-07-01 12:35:36 +0000
committergdt <gdt>2004-07-01 12:35:36 +0000
commitb2c1b282181af2244e738e9ea93296de17299bdc (patch)
treeee1f3dab6634ede9fe402bd0568244c079140d76 /ospfd/Makefile.am
parent87efd646ffef693235d9d29b005a1467373c51bd (diff)
Compile libospf shared as well.
Diffstat (limited to 'ospfd/Makefile.am')
-rw-r--r--ospfd/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/ospfd/Makefile.am b/ospfd/Makefile.am
index 7018b46c..68ce5265 100644
--- a/ospfd/Makefile.am
+++ b/ospfd/Makefile.am
@@ -4,10 +4,10 @@ INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
DEFS = @DEFS@ $(LOCAL_OPTS) -DSYSCONFDIR=\"$(sysconfdir)/\"
INSTALL_SDATA=@INSTALL@ -m 600
-lib_LIBRARIES = libospf.a
+lib_LTLIBRARIES = libospf.la
sbin_PROGRAMS = ospfd
-libospf_a_SOURCES = \
+libospf_la_SOURCES = \
ospfd.c ospf_zebra.c ospf_interface.c ospf_ism.c ospf_neighbor.c \
ospf_nsm.c ospf_dump.c ospf_network.c ospf_packet.c ospf_lsa.c \
ospf_spf.c ospf_route.c ospf_ase.c ospf_abr.c ospf_ia.c ospf_flood.c \
@@ -25,10 +25,9 @@ noinst_HEADERS = \
ospf_zebra.h ospf_spf.h ospf_route.h ospf_ase.h ospf_abr.h ospf_ia.h \
ospf_flood.h ospf_snmp.h ospf_te.h ospf_vty.h ospf_apiserver.h
-ospfd_SOURCES = \
- ospf_main.c $(libospf_a_SOURCES)
+ospfd_SOURCES = ospf_main.c
-ospfd_LDADD = -L../lib -lzebra @LIBCAP@
+ospfd_LDADD = libospf.la -L../lib -lzebra @LIBCAP@
EXTRA_DIST = OSPF-MIB.txt OSPF-TRAP-MIB.txt ChangeLog.opaque.txt