summaryrefslogtreecommitdiff
path: root/ospfd/Makefile.am
diff options
context:
space:
mode:
authorgdt <gdt>2004-07-23 16:23:56 +0000
committergdt <gdt>2004-07-23 16:23:56 +0000
commitb7a97f825768bb3e617cb115540c74b65914e628 (patch)
tree7614897d5d668291f854b5283daf424b55a12853 /ospfd/Makefile.am
parent33f92320e8a6b078a5972d05c8f49487d8edf19c (diff)
(somewhat unrelated cleanups, but all are very minor)
2004-07-23 Greg Troxel <gdt@poblano.ir.bbn.com> * */Makefile.am: Use ../dir/libfoo.la, rather than "-L../dir -lfoo", to avoid linking against installed libraries from a previous version. * {lib,ospfd,ospfclient}/Makefile.am: explicitly define the shared library version number to be 0.0 * configure.ac: remove spurious , so extract.pl is chmod'd +x. * HACKING: explain shared library versioning rules
Diffstat (limited to 'ospfd/Makefile.am')
-rw-r--r--ospfd/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/ospfd/Makefile.am b/ospfd/Makefile.am
index 68ce5265..fd03334a 100644
--- a/ospfd/Makefile.am
+++ b/ospfd/Makefile.am
@@ -5,6 +5,8 @@ DEFS = @DEFS@ $(LOCAL_OPTS) -DSYSCONFDIR=\"$(sysconfdir)/\"
INSTALL_SDATA=@INSTALL@ -m 600
lib_LTLIBRARIES = libospf.la
+libospf_la_LDFLAGS = -version 0:0:0
+
sbin_PROGRAMS = ospfd
libospf_la_SOURCES = \
@@ -27,7 +29,7 @@ noinst_HEADERS = \
ospfd_SOURCES = ospf_main.c
-ospfd_LDADD = libospf.la -L../lib -lzebra @LIBCAP@
+ospfd_LDADD = libospf.la ../lib/libzebra.la @LIBCAP@
EXTRA_DIST = OSPF-MIB.txt OSPF-TRAP-MIB.txt ChangeLog.opaque.txt