summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2006-01-10 14:49:04 +0000
committerpaul <paul>2006-01-10 14:49:04 +0000
commit067fca86323b189fabf4c64c0b9ccb98a458b981 (patch)
tree2a8b28a2cad3d1a956748204b7b20eecb63b1496 /tests/Makefile.am
parent4b201d46348b81bd9d59aa626c81f7457ea6ef38 (diff)
[tests] Add small unit test for the new stream functions
2006-01-10 Paul Jakma <paul.jakma@sun.com> * test-stream.c: new file, small unit test for new resize and {put,get}-quad stream functions. * Makefile.am: build teststream unit test.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4240ec11..94f7533d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,11 +2,12 @@ INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
DEFS = @DEFS@ $(LOCAL_OPTS) -DSYSCONFDIR=\"$(sysconfdir)/\"
noinst_PROGRAMS = testsig testbuffer testmemory heavy heavywq heavythread \
- aspathtest testprivs
+ aspathtest testprivs teststream
testsig_SOURCES = test-sig.c
testbuffer_SOURCES = test-buffer.c
testmemory_SOURCES = test-memory.c
testprivs_SOURCES = test-privs.c
+teststream_SOURCES = test-stream.c
heavy_SOURCES = heavy.c main.c
heavywq_SOURCES = heavy-wq.c main.c
heavythread_SOURCES = heavy-thread.c main.c
@@ -16,6 +17,7 @@ testsig_LDADD = ../lib/libzebra.la @LIBCAP@
testbuffer_LDADD = ../lib/libzebra.la @LIBCAP@
testmemory_LDADD = ../lib/libzebra.la @LIBCAP@
testprivs_LDADD = ../lib/libzebra.la @LIBCAP@
+teststream_LDADD = ../lib/libzebra.la @LIBCAP@
heavy_LDADD = ../lib/libzebra.la @LIBCAP@ -lm
heavywq_LDADD = ../lib/libzebra.la @LIBCAP@ -lm
heavythread_LDADD = ../lib/libzebra.la @LIBCAP@ -lm