summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2005-09-10 18:00:11 +0000
committerpaul <paul>2005-09-10 18:00:11 +0000
commit1f377b0202dfc4653f7717de964b628a369a9526 (patch)
treeff8718a3d40adbec8adeab994a32873bbbd4bacf /tests/Makefile.am
parentfe69a505f7be4357bf8523e3bbdced9c95590f3a (diff)
2005-09-06 Paul Jakma <paul@dishone.st>
* aspath_test.c: Test bgp_aspath functionality. * Makefile.am: build aspathtest * ChangeLog: Fix date of previous commit
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 67ea37ee..1449014d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,13 +1,15 @@
INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
DEFS = @DEFS@ $(LOCAL_OPTS) -DSYSCONFDIR=\"$(sysconfdir)/\"
-noinst_PROGRAMS = testsig testbuffer testmemory heavy heavywq heavythread
+noinst_PROGRAMS = testsig testbuffer testmemory heavy heavywq heavythread \
+ aspathtest
testsig_SOURCES = test-sig.c
testbuffer_SOURCES = test-buffer.c
testmemory_SOURCES = test-memory.c
heavy_SOURCES = heavy.c main.c
heavywq_SOURCES = heavy-wq.c main.c
heavythread_SOURCES = heavy-thread.c main.c
+aspathtest_SOURCES = aspath_test.c
testsig_LDADD = ../lib/libzebra.la @LIBCAP@
testbuffer_LDADD = ../lib/libzebra.la @LIBCAP@
@@ -15,3 +17,4 @@ testmemory_LDADD = ../lib/libzebra.la @LIBCAP@
heavy_LDADD = ../lib/libzebra.la @LIBCAP@ -lm
heavywq_LDADD = ../lib/libzebra.la @LIBCAP@ -lm
heavythread_LDADD = ../lib/libzebra.la @LIBCAP@ -lm
+aspathtest_LDADD = ../lib/libzebra.la @LIBCAP@ -lm ../bgpd/libbgp.a