summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2005-10-11 03:48:28 +0000
committerpaul <paul>2005-10-11 03:48:28 +0000
commit84771ee0deadae6d83b939a2d3f8f83cc420a829 (patch)
tree68b3e5c5cc6e84dd7d57a4bda2e61616d518a1a2 /tests/Makefile.am
parent77df1f78597af79209777d264ec9986f33a2fd17 (diff)
2005-10-11 Paul Jakma <paul.jakma@sun.com>
* test-privs.c: Privileges unit test. * Makefile.am: build testprivs * aspath_test.c: fix a few sign warnings
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1449014d..4240ec11 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,10 +2,11 @@ INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
DEFS = @DEFS@ $(LOCAL_OPTS) -DSYSCONFDIR=\"$(sysconfdir)/\"
noinst_PROGRAMS = testsig testbuffer testmemory heavy heavywq heavythread \
- aspathtest
+ aspathtest testprivs
testsig_SOURCES = test-sig.c
testbuffer_SOURCES = test-buffer.c
testmemory_SOURCES = test-memory.c
+testprivs_SOURCES = test-privs.c
heavy_SOURCES = heavy.c main.c
heavywq_SOURCES = heavy-wq.c main.c
heavythread_SOURCES = heavy-thread.c main.c
@@ -14,6 +15,7 @@ aspathtest_SOURCES = aspath_test.c
testsig_LDADD = ../lib/libzebra.la @LIBCAP@
testbuffer_LDADD = ../lib/libzebra.la @LIBCAP@
testmemory_LDADD = ../lib/libzebra.la @LIBCAP@
+testprivs_LDADD = ../lib/libzebra.la @LIBCAP@
heavy_LDADD = ../lib/libzebra.la @LIBCAP@ -lm
heavywq_LDADD = ../lib/libzebra.la @LIBCAP@ -lm
heavythread_LDADD = ../lib/libzebra.la @LIBCAP@ -lm