summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDavid Lamparter <equinox@opensourcerouting.org>2013-01-24 01:39:14 +0100
committerDavid Lamparter <equinox@diac24.net>2013-04-14 16:01:19 +0200
commitc69905b673812ce6ec2a12960727a27b9b8d6426 (patch)
tree2b7608b8d16bedfafbf734d5a0e8ff26646107f1 /tests/Makefile.am
parent5bb7e4d12b3a3015208fad5ee0f3c055b704c8c4 (diff)
tests: DejaGNU libzebra
Wrap the few libzebra test programs we have up for DejaGNU. Signed-off-by: David Lamparter <equinox@opensourcerouting.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 153922b9..93c06b03 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,12 +1,15 @@
AUTOMAKE_OPTIONS = dejagnu
export DEJAGNU
-DEJATOOL =
+DEJATOOL = libzebra
-SUBDIRS = bgpd.tests
+SUBDIRS = \
+ bgpd.tests \
+ libzebra.tests
EXTRA_DIST = \
config/unix.exp \
lib/bgpd.exp \
+ lib/libzebra.exp \
global-conf.exp
INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib -I$(top_builddir)/lib