summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDavid Lamparter <equinox@opensourcerouting.org>2013-02-26 16:21:20 +0100
committerDavid Lamparter <equinox@diac24.net>2013-04-14 16:01:05 +0200
commitf281ab9752393fcc7cbb54c50edb66f25c2a31fb (patch)
tree53be958c127d21c6bc0e2e2abd02f33a3fde16c2 /tests/Makefile.am
parentf2b53dac4c72811c06779c596c6162b994eb427a (diff)
tests: add DejaGNU framework
DejaGNU seems to be the 'standard' GNU test framework (which by itself doesn't say much), but it seems relatively usable and the "remote system" capabilities might come in handy for virtualisation-based tests for kernel interactions or something. Signed-off-by: David Lamparter <equinox@opensourcerouting.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7bc880b5..14f7bef1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,14 @@
+AUTOMAKE_OPTIONS = dejagnu
+export DEJAGNU
+
+SUBDIRS =
+
+EXTRA_DIST = \
+ config/unix.exp \
+ global-conf.exp
+
+DEJATOOL =
+
INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib -I$(top_builddir)/lib
DEFS = @DEFS@ $(LOCAL_OPTS) -DSYSCONFDIR=\"$(sysconfdir)/\"