summaryrefslogtreecommitdiff
path: root/vtysh/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2003-10-24 04:39:18 +0000
committerpaul <paul>2003-10-24 04:39:18 +0000
commita652604cbfcc87884a00b12beb4e63b1eb10bcea (patch)
tree1ce5527c8410d474d0882212fe1a4c4cb9a89427 /vtysh/Makefile.am
parent04bd484bf272dd580349c832f84cf5ffa27003bb (diff)
2003-10-24 waldi@debian.org
* vtysh/Makefile.am: vtysh_cmd.c rebuild was broken because it depended against source files without specification, i.e. it used ../zebra instead of $(top_srcdir)/zebra.
Diffstat (limited to 'vtysh/Makefile.am')
-rw-r--r--vtysh/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/vtysh/Makefile.am b/vtysh/Makefile.am
index 33064e10..b5f964e5 100644
--- a/vtysh/Makefile.am
+++ b/vtysh/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with Automake to create Makefile.in
-INCLUDES = @INCLUDES@ -I.. -I$(top_srcdir) -I$(top_srcdir)/lib
+INCLUDES = @INCLUDES@ -I$(top_srcdir) -I$(top_srcdir)/lib
DEFS = @DEFS@ -DSYSCONFDIR=\"$(sysconfdir)/\"
LIBS = @LIBS@ @CURSES@ @LIBPAM@
@@ -17,13 +17,13 @@ sysconf_DATA = vtysh.conf.sample
EXTRA_DIST = extract.pl vtysh.conf.sample
rebuild4:
- ./extract.pl ../zebra/*.c ../ripd/*.c ../ospfd/*.c ../bgpd/*.c ../lib/keychain.c ../lib/routemap.c ../lib/filter.c ../lib/plist.c ../lib/distribute.c ../lib/if_rmap.c > vtysh_cmd.c
-
-vtysh_cmd.c: ../zebra/*.c ../ripd/*.c ../ripngd/*.c ../ospfd/*.c \
- ../ospf6d/*.c ../bgpd/*.c ../lib/keychain.c ../lib/routemap.c \
- ../lib/filter.c ../lib/plist.c ../lib/distribute.c ../lib/if_rmap.c
- ./extract.pl ../zebra/*.c ../ripd/*.c ../ripngd/*.c ../ospfd/*.c \
- ../ospf6d/*.c ../bgpd/*.c ../lib/keychain.c ../lib/routemap.c \
- ../lib/filter.c ../lib/plist.c ../lib/distribute.c \
- ../lib/if_rmap.c > vtysh_cmd.c
+ ./extract.pl $(top_srcdir)/zebra/*.c $(top_srcdir)/ripd/*.c $(top_srcdir)/ospfd/*.c $(top_srcdir)/bgpd/*.c $(top_srcdir)/lib/keychain.c $(top_srcdir)/lib/routemap.c $(top_srcdir)/lib/filter.c $(top_srcdir)/lib/plist.c $(top_srcdir)/lib/distribute.c $(top_srcdir)/lib/if_rmap.c > vtysh_cmd.c
+
+vtysh_cmd.c: $(top_srcdir)/zebra/*.c $(top_srcdir)/ripd/*.c $(top_srcdir)/ripngd/*.c $(top_srcdir)/ospfd/*.c \
+ $(top_srcdir)/ospf6d/*.c $(top_srcdir)/bgpd/*.c $(top_srcdir)/lib/keychain.c $(top_srcdir)/lib/routemap.c \
+ $(top_srcdir)/lib/filter.c $(top_srcdir)/lib/plist.c $(top_srcdir)/lib/distribute.c $(top_srcdir)/lib/if_rmap.c
+ $(srcdir)/extract.pl $(top_srcdir)/zebra/*.c $(top_srcdir)/ripd/*.c $(top_srcdir)/ripngd/*.c $(top_srcdir)/ospfd/*.c \
+ $(top_srcdir)/ospf6d/*.c $(top_srcdir)/bgpd/*.c $(top_srcdir)/lib/keychain.c $(top_srcdir)/lib/routemap.c \
+ $(top_srcdir)/lib/filter.c $(top_srcdir)/lib/plist.c $(top_srcdir)/lib/distribute.c \
+ $(top_srcdir)/lib/if_rmap.c > vtysh_cmd.c