summaryrefslogtreecommitdiff
path: root/vtysh/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2003-07-12 21:46:53 +0000
committerpaul <paul>2003-07-12 21:46:53 +0000
commitf706c10c828a0526326af42d95238b2cd3eb06d1 (patch)
treeff98648a5efeb480d5a837d878ea58375a9241a4 /vtysh/Makefile.am
parent9abb7b7894f2d6f279bd94e979194d532b1124ce (diff)
2003-07-12 Paul Jakma <paul@dishone.st>
* vtysh/Makefile.am: explicitely list the files required for vtysh_cmd.c to be generated, to minimise spurious rebuilds.
Diffstat (limited to 'vtysh/Makefile.am')
-rw-r--r--vtysh/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/vtysh/Makefile.am b/vtysh/Makefile.am
index 7a21409f..eef28542 100644
--- a/vtysh/Makefile.am
+++ b/vtysh/Makefile.am
@@ -18,7 +18,11 @@ EXTRA_DIST = extract.pl vtysh.conf.sample
rebuild4:
./extract.pl ../zebra/*.c ../ripd/*.c ../ospfd/*.c ../bgpd/*.c ../lib/keychain.c ../lib/routemap.c ../lib/filter.c ../lib/plist.c ../lib/distribute.c ../lib/if_rmap.c > vtysh_cmd.c
-rebuild:
- ./extract.pl ../zebra/*.c ../ripd/*.c ../ripngd/*.c ../ospfd/*.c ../ospf6d/*.c ../bgpd/*.c ../lib/keychain.c ../lib/routemap.c ../lib/filter.c ../lib/plist.c ../lib/distribute.c ../lib/if_rmap.c > vtysh_cmd.c
+vtysh_cmd.c: ../zebra/*.c ../ripd/*.c ../ripngd/*.c ../ospfd/*.c \
+ ../ospf6d/*.c ../bgpd/*.c ../lib/keychain.c ../lib/routemap.c \
+ ../lib/filter.c ../lib/plist.c ../lib/distribute.c ../lib/if_rmap.c
+ ./extract.pl ../zebra/*.c ../ripd/*.c ../ripngd/*.c ../ospfd/*.c \
+ ../ospf6d/*.c ../bgpd/*.c ../lib/keychain.c ../lib/routemap.c \
+ ../lib/filter.c ../lib/plist.c ../lib/distribute.c \
+ ../lib/if_rmap.c > vtysh_cmd.c
-vtysh_cmd.c: rebuild