summaryrefslogtreecommitdiff
path: root/zebra/Makefile.am
diff options
context:
space:
mode:
authorPaul Jakma <paul.jakma@sun.com>2006-07-27 19:59:58 +0000
committerPaul Jakma <paul.jakma@sun.com>2006-07-27 19:59:58 +0000
commit457eb9af72e6e7aa85c26b65ba4d053f9ecbffac (patch)
treeca93002285032e0c845749cfd770a446a9fc702b /zebra/Makefile.am
parent1893740016d35d75de567a5f6b74db2314ffdc52 (diff)
[zebra] Add test rig code, for testing the zebra RIB
2006-07-27 Paul Jakma <paul.jakma@sun.com> * {ioctl,kernel}_null.c: Dummy/Null kernel method implementations, useful for testing zebra code that calls such methods. * {redistribute,misc}_null.c: Dummy/Null methods, as above. But for zclient, and for various misc functions. * test_main.c: Test harness for zebra, currently just to test the RIB. * Makefile.am: Build testzebra using above. * zebra_rib.c: Add a global for the workqueue hold time, useful for testing.
Diffstat (limited to 'zebra/Makefile.am')
-rw-r--r--zebra/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/zebra/Makefile.am b/zebra/Makefile.am
index 751f606f..7527562a 100644
--- a/zebra/Makefile.am
+++ b/zebra/Makefile.am
@@ -21,17 +21,25 @@ otherobj = $(ioctl_method) $(ipforward) $(if_method) $(if_proc) \
sbin_PROGRAMS = zebra
+noinst_PROGRAMS = testzebra
+
zebra_SOURCES = \
zserv.c main.c interface.c connected.c zebra_rib.c \
redistribute.c debug.c rtadv.c zebra_snmp.c zebra_vty.c \
irdp_main.c irdp_interface.c irdp_packet.c router-id.c
+testzebra_SOURCES = test_main.c zebra_rib.c interface.c connected.c debug.c \
+ zebra_vty.c \
+ kernel_null.c redistribute_null.c ioctl_null.c misc_null.c
+
noinst_HEADERS = \
connected.h ioctl.h rib.h rt.h zserv.h redistribute.h debug.h rtadv.h \
interface.h ipforward.h irdp.h router-id.h kernel_socket.h
zebra_LDADD = $(otherobj) $(LIBCAP) $(LIB_IPV6) ../lib/libzebra.la
+testzebra_LDADD = $(LIBCAP) $(LIB_IPV6) ../lib/libzebra.la
+
zebra_DEPENDENCIES = $(otherobj)
EXTRA_DIST = if_ioctl.c if_ioctl_solaris.c if_netlink.c if_proc.c \