summaryrefslogtreecommitdiff
path: root/zebra/Makefile.am
diff options
context:
space:
mode:
authorgdt <gdt>2003-12-03 17:24:27 +0000
committergdt <gdt>2003-12-03 17:24:27 +0000
commitd6b72f7ab1d33a43e1b6d5cd3410ac53e3bf74a9 (patch)
treee2b2a025757c52802bc12a4b6b8eec94d4bcdd79 /zebra/Makefile.am
parent6c110e700c21ef3d1d958da1df54261960d7ef07 (diff)
Add support for --enable-exampledir to specify where to place example
files, defaulting to sysconfdir (matching previous behavior). This is needed to support (cleanly) NetBSD pkgsrc, which requires that example config files go in $(prefix)/share/examples/pkgname, rather than in $(prefix)/etc/pkgname.
Diffstat (limited to 'zebra/Makefile.am')
-rw-r--r--zebra/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/zebra/Makefile.am b/zebra/Makefile.am
index d449fe16..6f8e9542 100644
--- a/zebra/Makefile.am
+++ b/zebra/Makefile.am
@@ -43,4 +43,6 @@ EXTRA_DIST = if_ioctl.c if_netlink.c if_proc.c if_sysctl.c \
# $(CC) -g -o client client_main.o ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
quaggaconfdir = $(sysconfdir)
-dist_quaggaconf_DATA = zebra.conf.sample
+
+examplesdir = $(exampledir)
+dist_examples_DATA = zebra.conf.sample