summaryrefslogtreecommitdiff
path: root/zebra/Makefile.am
diff options
context:
space:
mode:
authorpaul <paul>2005-11-24 15:15:17 +0000
committerpaul <paul>2005-11-24 15:15:17 +0000
commitec1a428343cad343969d569c56acbe6b02ab8f4f (patch)
treeed693dcea011eccbef34113da3e340ec1290e7b3 /zebra/Makefile.am
parentb6026073584b855d47a8e2033d2aa3413a3394e9 (diff)
[zebra] Fix mistake in previous commit and further compile warnings/errors.
2005-11-24 Paul Jakma <paul.jakma@sun.com> * kernel_socket.h: New header for functions exported to sysctl methods. * kernel_socket.c: include previous. Remove static qualifier from couple of functions which are used by sysctl methods, incorrectly added in previous commit. Add a workaround for a bogus gcc warning to the RTA_ macros. * Makefile.am: Add kernel_socket.h to noinst_HEADERS * if_sysctl.c: include rt.h and kernel_socket.h and remove redundant prototypes. * rtread_sysctl.c: ditto. (route_read) fix mismatch of return values. * {rt,zserv,rib}.h: Include lib headers depended on.
Diffstat (limited to 'zebra/Makefile.am')
-rw-r--r--zebra/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/zebra/Makefile.am b/zebra/Makefile.am
index 7dc495e9..751f606f 100644
--- a/zebra/Makefile.am
+++ b/zebra/Makefile.am
@@ -28,7 +28,7 @@ zebra_SOURCES = \
noinst_HEADERS = \
connected.h ioctl.h rib.h rt.h zserv.h redistribute.h debug.h rtadv.h \
- interface.h ipforward.h irdp.h router-id.h
+ interface.h ipforward.h irdp.h router-id.h kernel_socket.h
zebra_LDADD = $(otherobj) $(LIBCAP) $(LIB_IPV6) ../lib/libzebra.la