summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorhasso <hasso>2005-03-28 15:29:07 +0000
committerhasso <hasso>2005-03-28 15:29:07 +0000
commit2d58228ecabb23b064e8a06e6241cf0d7e5ca785 (patch)
tree443509e8113598c7dadaa5e9cdbb153c147d0ffe /configure.ac
parent17eff7cb9010c0ba386ab801c220811ded4242b3 (diff)
* configure.ac, */Makefile.am: Fix previous commit. SNMP includes
must be after lib/ includes in some systems. Introduce SNMP_INCLUDES for that.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index def16cbe..508ba7d3 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
## Copyright (c) 1996, 97, 98, 99, 2000 Kunihiro Ishiguro <kunihiro@zebra.org>
## Portions Copyright (c) 2003 Paul Jakma <paul@dishone.st>
##
-## $Id: configure.ac,v 1.93 2005/03/27 21:00:35 hasso Exp $
+## $Id: configure.ac,v 1.94 2005/03/28 15:29:07 hasso Exp $
AC_PREREQ(2.53)
AC_INIT(Quagga, 0.99.0, [http://bugzilla.quagga.net])
@@ -948,7 +948,7 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
AC_DEFINE(HAVE_SNMP,,SNMP)
AC_DEFINE(HAVE_NETSNMP,,SNMP)
AC_DEFINE(UCD_COMPATIBLE,,SNMP)
- INCLUDES="${INCLUDES} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
+ SNMP_INCLUDES="${SNMP_INCLUDES} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
if test "${HAVE_NETSNMP}" = "yes"; then
LIBS="${LIBS} -lnetsnmp"
else
@@ -957,19 +957,19 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
;;
/usr/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
- INCLUDES="${INCLUDES} -I/usr/include/ucd-snmp"
+ SNMP_INCLUDES="${SNMP_INCLUDES} -I/usr/include/ucd-snmp"
LIBS="${LIBS} -lsnmp"
;;
/usr/local/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
- INCLUDES="${INCLUDES} -I/usr/local/include/ucd-snmp"
+ SNMP_INCLUDES="${SNMP_INCLUDES} -I/usr/local/include/ucd-snmp"
LIBS="${LIBS} -L/usr/local/lib -lsnmp"
;;
/usr/local/include/net-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
AC_DEFINE(HAVE_NET_SNMP,,SNMP)
AC_DEFINE(UCD_COMPATIBLE,,SNMP)
- INCLUDES="${INCLUDES} -I/usr/local/include/net-snmp"
+ SNMP_INCLUDES="${SNMP_INCLUDES} -I/usr/local/include/net-snmp"
LIBS="${LIBS} -L/usr/local/lib -lnetsnmp"
;;
esac
@@ -983,6 +983,8 @@ if test "${enable_snmp}" = "yes" -a "${HAVE_SNMP}" != "yes"; then
AC_MSG_ERROR([--enable-snmp given, but cannot find support for SNMP])
fi
+AC_SUBST(SNMP_INCLUDES)
+
dnl ----------------------------
dnl check sa_len of sockaddr
dnl ----------------------------
@@ -1280,7 +1282,7 @@ host operationg system : ${host_os}
source code location : ${srcdir}
compiler : ${CC}
compiler flags : ${CFLAGS}
-includes : ${INCLUDES}
+includes : ${INCLUDES} ${SNMP_INCLUDES}
linker flags : ${LDFLAGS} ${LIBS}
state file directory : ${quagga_statedir}
config file directory : `eval echo \`echo ${sysconfdir}\``