summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDoug VanLeuven <roamdad@sonic.net>2012-12-14 14:58:30 +0200
committerDavid Lamparter <equinox@opensourcerouting.org>2013-01-11 21:50:06 +0100
commit327c4cdf7578debcc140f04f03d02479771c9e11 (patch)
treea0e02a0614f12601d8a58eeeebf9e54b27198c9f /configure.ac
parentb2e5bdbe10c4145f508fcf1486ffe29d5ce516f7 (diff)
testzebra: pragma weak: detect systems with weak alias and provide alternative
LLVM clang does not support #pragma weak (bug 3679) on OS X. There are other systems where the #pragma weak has varying syntax. Added m4 file from the autoconf archives: http://www.gnu.org/software/autoconf-archive/ax_sys_weak_alias.html Fix up zebra/*_null.c files to use #pragma weak alias or stub functions if not available. It's incomplete in that the different format #pragma enable easier fixes on need. Tested on 64bit OS X 10.7, FreeBSD 9.0 amd64 & i386 (32bit) using gcc & clang. Tested on linux 64bit. Signed-off-by: David Lamparter <equinox@opensourcerouting.org>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 405693c9..c51a0d3e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1540,6 +1540,22 @@ if test "${enable_capabilities}" != "no"; then
fi
AC_SUBST(LIBCAP)
+dnl ---------------------------------------------------------------------------
+dnl http://www.gnu.org/software/autoconf-archive/ax_sys_weak_alias.html
+dnl Check for and set one of the following = 1
+dnl HAVE_SYS_WEAK_ALIAS_ATTRIBUTE
+dnl HAVE_SYS_WEAK_ALIAS_PRAGMA
+dnl HAVE_SYS_WEAK_ALIAS_HPSECONDARY
+dnl HAVE_SYS_WEAK_ALIAS_CRIDUPLICATE
+dnl If any scheme is found, set
+dnl HAVE_SYS_WEAK_ALIAS=1
+dnl The following variable is set to text value
+dnl WEAK_ALIAS = "attribute" || "pragma" || "hpsecondary" || "criduplicate" || "no"
+dnl If weak alias can cross object file boundaries
+dnl WEAK_ALIAS_CROSSFILE = "yes" || "no"
+dnl ---------------------------------------------------------------------------
+AX_SYS_WEAK_ALIAS
+
dnl ---------------------------
dnl check for glibc 'backtrace'
dnl ---------------------------