summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 405693c9..c51a0d3e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1540,6 +1540,22 @@ if test "${enable_capabilities}" != "no"; then
fi
AC_SUBST(LIBCAP)
+dnl ---------------------------------------------------------------------------
+dnl http://www.gnu.org/software/autoconf-archive/ax_sys_weak_alias.html
+dnl Check for and set one of the following = 1
+dnl HAVE_SYS_WEAK_ALIAS_ATTRIBUTE
+dnl HAVE_SYS_WEAK_ALIAS_PRAGMA
+dnl HAVE_SYS_WEAK_ALIAS_HPSECONDARY
+dnl HAVE_SYS_WEAK_ALIAS_CRIDUPLICATE
+dnl If any scheme is found, set
+dnl HAVE_SYS_WEAK_ALIAS=1
+dnl The following variable is set to text value
+dnl WEAK_ALIAS = "attribute" || "pragma" || "hpsecondary" || "criduplicate" || "no"
+dnl If weak alias can cross object file boundaries
+dnl WEAK_ALIAS_CROSSFILE = "yes" || "no"
+dnl ---------------------------------------------------------------------------
+AX_SYS_WEAK_ALIAS
+
dnl ---------------------------
dnl check for glibc 'backtrace'
dnl ---------------------------