summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorajs <ajs>2005-01-12 17:27:27 +0000
committerajs <ajs>2005-01-12 17:27:27 +0000
commit40abf2392ba9f14935dab556f43e674cb5c47cf3 (patch)
tree3c5ff5794940f408b411c5d0204e27dac1014378 /configure.ac
parent6cf9df088e10baefe04139897f8745a42ea0c772 (diff)
2005-01-12 Andrew J. Schorr <ajschorr@alumni.princeton.edu>
* configure.ac: Test for header file <ucontext.h> (for use in signal processing). * sigevent.c: (trap_default_signals) Use the SA_SIGINFO flag to pass additional siginfo_t and ucontext_t arguments to core_handler and exit_handler. (core_handler,exit_handler) Now invoked with 3 arguments (using SA_SIGINFO). Pass additional info to zlog_signal. (program_counter) New function to find program counter in ucontext_t, needs to be enhanced to support more platforms (currently works only on Linux/x86). * log.h: Change the zlog_signal prototype to add new arguments siginfo_t * and program_counter. * log.c: (zlog_signal) Add new arguments siginfo and program_counter. Include si_addr and program counter (if non-NULL) in message. And remove #ifdef HAVE_GLIBC_BACKTRACE around hex_append, since that is now used to render the si_addr and PC pointers.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 61a00d95..ff424e8b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
## Copyright (c) 1996, 97, 98, 99, 2000 Kunihiro Ishiguro <kunihiro@zebra.org>
## Portions Copyright (c) 2003 Paul Jakma <paul@dishone.st>
##
-## $Id: configure.ac,v 1.86 2005/01/12 16:52:55 ajs Exp $
+## $Id: configure.ac,v 1.87 2005/01/12 17:27:27 ajs Exp $
AC_PREREQ(2.53)
AC_INIT(Quagga, 0.98.0, [http://bugzilla.quagga.net])
@@ -1107,6 +1107,11 @@ if test "${enable_capabilities}" != "no"; then
fi
AC_SUBST(LIBCAP)
+dnl -------------------
+dnl test for ucontext.h
+dnl -------------------
+AC_CHECK_HEADERS(ucontext.h)
+
dnl ---------------------------
dnl check for glibc 'backtrace'
dnl ---------------------------