summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-06-06 12:19:53 +0000
committerpaul <paul>2003-06-06 12:19:53 +0000
commit79cb216984c0f93e80e01e9fed6022ad27a25825 (patch)
tree2f00c2d2e19b9dc35b231f3db094e9fb6b3c924e /configure.ac
parent8d4aee5d510fab69561dba58dc9fc0b6f1838aa1 (diff)
2003-06-06 Paul Jakma <paul@dishone.st>
* Fix up defaults for --enable-{user,group}
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3f19601e..000729be 100755
--- a/configure.ac
+++ b/configure.ac
@@ -143,14 +143,14 @@ else
AC_MSG_RESULT(no)
fi
-if test "${enable_user}" = "yes" ; then
+if test "${enable_user}" = "yes" || test x"${enable_user}" = x""; then
enable_user="zebra"
elif test "${enable_user}" = "no"; then
enable_user="root"
fi
AC_DEFINE_UNQUOTED(ZEBRA_USER, "${enable_user}", Zebra User)
-if test "${enable_group}" = "yes" ; then
+if test "${enable_group}" = "yes" || test x"${enable_group}" = x""; then
enable_group="zebra"
elif test "${enable_group}" = "no"; then
enable_group="root"
@@ -159,8 +159,7 @@ AC_DEFINE_UNQUOTED(ZEBRA_GROUP, "${enable_group}", Zebra Group)
if test x"${enable_vty_group}" = x"yes" ; then
AC_MSG_ERROR([--enable-vty-group requires a group as argument, not yes])
-fi
-if test x"${enable_vty_group}" != x""; then
+elif test x"${enable_vty_group}" != x""; then
if test x"${enable_vty_group}" != x"no"; then
AC_DEFINE_UNQUOTED(VTY_GROUP, "${enable_vty_group}", VTY Sockets Group)
fi