summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorgdt <gdt>2003-12-04 15:39:25 +0000
committergdt <gdt>2003-12-04 15:39:25 +0000
commitc4f0efe676e5243711d418925991411eb5efeea4 (patch)
treec17ed5b9adc3d69e9057da22c4285075ce300bbc /configure.ac
parentd2a0ccc634dec98d0498c082ba49c069aaee0fae (diff)
fix exampledir processing bug; it failed when neither exampledir nor
sysconfdir were specified, due to incorrect extra quoting of sysconfdir. Thanks to Vincent Jardin for the bug report.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 725ce72f..b6d8829f 100755
--- a/configure.ac
+++ b/configure.ac
@@ -13,12 +13,12 @@ AM_INIT_AUTOMAKE()
AM_CONFIG_HEADER(config.h)
dnl default is to match previous behavior
-exampledir='${sysconfdir}'
+exampledir=${sysconfdir}
AC_ARG_ENABLE([exampledir],
AC_HELP_STRING([--enable-exampledir],
[specify alternate directory for examples]),
exampledir="$enableval",)
-dnl XXX hook into argument processing
+dnl XXX add --exampledir to autoconf standard directory list somehow
AC_SUBST(exampledir)
dnl -----------------------------------